Project

General

Profile

Bug #54

Remote-storage port(s) are disconnected while still in use

Added by jahoti 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Urgent
Assignee:
Start date:
07/17/2021
Due date:
% Done:

0%

Estimated time:

Description

Potentially there are other issues with storage, and the situation may not even be limited to Gecko; however, these are all the details currently available.

History

#1

Updated by koszko 6 months ago

That's possible. I've been fighting these ports also when making the popup page.

Any additional details as to how to reproduce the error? I guess it must have something to do with closing of the settings page?

#2

Updated by jahoti 6 months ago

Any additional details as to how to reproduce the error? I guess it must have something to do with closing of the settings page?

Not yet- as soon as the next update to nonce-handling is pushed that will be my priority!

#3

Updated by jahoti 6 months ago

The issue, it turns out, can be reproduced by opening the popup on an unprivileged page and then playing with the settings. Could the popup disconnecting a port have something to do with this?

#4

Updated by koszko 6 months ago

  • Subject changed from Remote-storage port(s) are disconnected while still in use on Gecko to Remote-storage port(s) are disconnected while still in use
  • Status changed from New to In Progress
  • Assignee changed from jahoti to koszko
  • Priority changed from Normal to Urgent

Yes, I seems to happen exclusively after "View in settings" or "Edit in settings" is used. I now know that I introduced it in https://git.koszko.org/browser-extension/commit/?id=c86bdfcd9d56309faca69b58830cea1fa98870e0

#5

Updated by koszko 6 months ago

Turns out it was a page_info_server error caused by a typo (missed underscore caused some storage change callback not to get deregistered automatically after port disconnect 🤦).

I additionally found another bug and fixed it. It's all in master now

#6

Updated by koszko 6 months ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF